KB2019.915
Domain Time loses PTP sync and reports its state as faulty.

This article applies to Domain Time Client and Domain Time Server.

Last Updated: 20 Jul 2021

Problem

    Domain Time will not stay synchronized to the PTP Master and reports its state as faulty on the PTP Status page of the applet. You also receive log messages similar to this:

    PTP detected 192.168.1.50 with same portIdentity (408d5c-fffe-e775e9.1) as this node; setting state to faulty

Cause

    PTP requires each node (Master and Slaves) to have a unique portIdentity since it uses this value to direct data to the correct machine. Domain Time checks to be sure it has a unique value. If it detects a duplicate, it will disable PTP sync to avoid causing issues with the duplicate machine and report its synchronization state as faulty.

Explanation

    portIdentity consists of a clockIdentity value plus a port number. Many devices, particularly PTP-capable Network Interface Controllers (NICs) derive the PTP clockIdentity value from their assigned MAC address. Domain Time does this as well. However, if Domain Time is installed on a machine that also has a PTP-aware NIC, portIdentity conflicts can occur if both Domain Time and NIC derived their values from the NIC MAC address. For example, PTP-aware NICs will often assign themselves a single clockIdentity value derived from the MAC address, but assign a individual port number for each network interface on the card, starting with port 1 and incrementing for each additional port.

    Also, a portIdentity conflict with other machines can be identified over the network. This can happen if Domain Time instances have been cloned without removing machine-specific information (see KB2008.090), resulting in duplicate portIdentity combinations. It can also happen if some other PTP device has been configured with a duplicate portIdentity.

Solution

    You may resolve this error in several ways, depending on the cause:

    1. If Domain Time is installed on a machine with a PTP-capable NIC, you can manually change the clockIdentity value from the PTP Options -> Advanced dialog page of the applet. Pick a unique value with the same number of digits. It's usually easiest to simply change the first or last digit of the existing number.

    2. You can also resolve portIdentity conflicts by manually changing the port number assigned to Domain Time. This value is set using the HKLM\SOFTWARE\Greyware\Domain Time Server\Time Sources\PTPv2 (IEEE 1588)\PortNumber Cache registry setting. Note that if the conflict is caused by a NIC card with multiple ports, you'll need to pick a port number high enough to avoid the number of port numbers assigned to the NIC.

    3. If Domain Time is detecting a duplicate from another Domain Time installation that was cloned, please follow the steps on KB2008.090 to remove the duplicated information.

    4. If the detected duplicate is another PTP device, you should examine the device to be sure it's using a unique number. Or, you may change the Domain Time clockIdentity as in step 1 or port number as in step 2 above.

    For more information, see portIdentity

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